Command Center & Business Center - Unable to access

Incident Report for Thryv

Resolved

This incident has been resolved.
Posted Mar 25, 2025 - 16:56 CDT

Monitoring

A fix for the issue was implemented and the errors are subsiding. It is estimated that the errors will be fully resolved in the next 15 minutes. We are continuing to monitor for any further disruptions.
Posted Mar 25, 2025 - 14:10 CDT

Identified

Our development team has identified the root cause and is working on implementing a fix. Additional updates will be provided once available.
Posted Mar 25, 2025 - 13:50 CDT

Update

We are continuing to investigate this issue.
Posted Mar 25, 2025 - 13:43 CDT

Investigating

Current Status: Outage
Discovered: 3/25/25 1 PM CST
Resolved:

Impacted Product: Command Center, Business Center
Affected Feature: Command Center & Business Center access/login

What does this mean for you?
Command Center and Business Center users are currently unable to access the Thryv Command Center and Business Center. An error message occurs stating unable to login successfully even if the correct email/password is used. Our development team is aware of the issue and is working on a resolution with the highest priority. Users will also be unable to access their Business Center (through Command Center), Marketing Center, Thryv Leads, and other Thryv software features at this time.

Current Workaround:

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Mar 25, 2025 - 13:35 CDT
This incident affected: Business Center (Business Center), Thryv Leads (Thryv Leads - Business Center), Command Center (Command Center Inbox), and Marketing (Marketing Center).