Business Center - Onboarding Wizard
Incident Report for Thryv
Resolved
This incident has been resolved, the Onboarding Wizard is now functioning as expected. We will continue to monitor the Onboarding Wizard for any disruptions.
Posted Nov 07, 2024 - 13:15 CST
Update
We are continuing to investigate this issue.
Posted Nov 07, 2024 - 09:23 CST
Investigating
We are currently investigating an issue with our Onboarding Wizard for Business Center preventing us from completing the Onboarding Process.

Issue Experience: Users will see an error stating the account information could not be retrieved and will not be able to continue with Onboarding.

This incident is currently effecting:

Users: Global
Device/OS: Desktop/Browser
Effected Component: Onboarding Wizard
Current Workaround: no current workaround
Estimated Timeline to Resolution: No ETA


We will continue to provide regular updates here regarding the incident.
Posted Nov 07, 2024 - 09:15 CST
This incident affected: Business Center (Business Center).