Business Center - Unable to edit appointments

Incident Report for Thryv

Resolved

This incident has been resolved.
Posted Aug 25, 2025 - 13:26 CDT

Investigating

Current Status: Partially Operational
Discovered: 8/25/2025 10:20 AM CT
Resolved: 8/25/2025 1:20 PM CT

Impacted Product: Business Center
Affected Feature: Thryv Calendar

What does this mean for you?
When attempting to edit an appointment from the Thryv Calendar, the page will freeze, and the edit button is unresponsive.

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Aug 25, 2025 - 10:43 CDT
This incident affected: Calendar (Calendar).