Our development team has implemented a number of measures that has mitigated the issue with delays when sending announcements. The root cause is still being investigated further to ensure the issue is fully resolved.
Posted Apr 02, 2025 - 10:48 CDT
Update
Our development team continues to investigate the root cause of the delay in sending Announcements. Further updates or workarounds will be provided once available.
Posted Mar 13, 2025 - 13:24 CDT
Investigating
Current Status: Degraded Performance Discovered: 3/6/2025 Resolved:
Impacted Product: Business Center Affected Feature: Marketing - Email Announcements
What does this mean for you? Users are experiencing issues when sending an Announcement using the "Send Now" option. The Announcement is not sending right away despite using the Send Now option and is being delayed from sending, in some cases for multiple hours. We are investigating the root cause with high urgency.
Current Workaround: No current workaround. The Announcement send eventually. Users should not attempt to send the same Announcement multiple times.
We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Mar 07, 2025 - 13:38 CST
This incident affects: Marketing (Announcements (Email)).