Business Center - Blank Page: Multiple Features

Incident Report for Thryv

Resolved

This incident has been resolved.
Posted Apr 02, 2025 - 10:45 CDT

Monitoring

A fix has been implemented and all Business Center features are working as intended. We will continue to monitor for any further disruptions.
Posted Apr 02, 2025 - 10:30 CDT

Identified

A fix has been implemented that has resolved the error causing a blank page to display for the listed features. However, users are now experiencing an issue where the page "sticks" when navigating from one impacted feature to another. Refreshing the page will also resolve this as a workaround and allow the page to load. It is recommended for mobile app users to access the Business Center on a mobile browser for the time being so that the refresh page option may be used to resolve any stuck pages.
Posted Apr 01, 2025 - 15:06 CDT

Update

Our team continues to investigate the root cause of this issue. As a current workaround accessing any of the impacted features and then refreshing the page will allow the page to load properly.
Posted Apr 01, 2025 - 13:10 CDT

Investigating

Current Status: Partially Operational
Discovered: 4/1/2025 9:30AM CST
Resolved:

Impacted Product: Business Center
Affected Feature: ThryvPay, Online Listings Management, TeamChat, Google Profile, Social, Reputation (reviews), Signature Requests

What does this mean for you?
Users are seeing a blank page when attempting to access the features listed above in their Business Center. Other features in the Business Center are working as intended.

Current Workaround: no current workaround

We are working diligently to resolve this issue; we will provide ongoing status updates.
Posted Apr 01, 2025 - 11:52 CDT
This incident affected: Business Center (Business Center TeamChat App, Reputation - Review Response, Business Center Listings Management, Business Center Google Business Profile, BC ThryvPay Tab, Signature Requests, Business Center Social).