Android Users unable to access Business Center mobile app
Incident Report for Thryv
Resolved
This issue is now resolved and full functionality has been restored.
Posted Oct 24, 2023 - 18:02 CDT
Investigating
We are currently investigating an issue where android users are unable to access the business center mobile app.

Issue Experience: When android users attempt to access the business center mobile app they receive an alert that the app has a bug and will not open.

This incident is currently effecting:

Users: (Android Mobile users)
Device/OS: (Android phones)
Effected Component: (Business center mobile app)
Current Workaround: (You may still access Business center by using your mobile browser or desktop browser and visiting login.thryv.com)
Estimated Timeline to Resolution: We are working to resolve this as quickly as possible.


We will continue to provide regular updates here regarding the incident.
Posted Oct 24, 2023 - 14:28 CDT
This incident affected: Mobile App (Mobile App).