Update
We will be undergoing scheduled maintenance during this time.
Posted Feb 10, 2026 - 14:03 CST
Scheduled
We have a planned maintenance window to upgrade our underlying infrastructure. During this time, the Business Center will be temporarily unavailable, and users will not be able to log in or access platform features until it is complete.
US Central (CT): Saturday, February 14, 2026 at 11:00pm to Sunday, February 15, 2026 at 1:00am
Posted Feb 10, 2026 - 12:33 CST
This scheduled maintenance affects: Business Center (Business Center, Dashboard, Business Center TeamChat App, Calendar, Clients (CRM), Sales - Invoicing, Estimates, Payments, Documents, Client Portal, Reputation - Review Response, Website Widgets, Website, Business Page, Reserve with Google, Email Signature (Online Presence), Business Center Listings Management, Business Center Google Business Profile, Business Center App Market (4.0 only), Settings, BC ThryvPay Tab, ThryvLeads Reporting Access - BC, Signature Requests, Business Center Social, Business Center Inbox (4.0 only), Email Messages (inbound), Email Messages (outbound), SMS Messages (inbound), SMS Messages (outbound), App Market, Listings Management, Social Content, Business Center Mobile App, Thryv Leads - Business Center).