A fix has been implemented and we are seeing the ThryvPay platform return to functioning normally. We will continue to monitor for any further disruptions.
Posted Mar 11, 2026 - 16:19 CDT
Identified
Discovered: 2:50pm CT Resolved:
Impacted Product: ThryvPay Affected Feature: All features
What does this mean for you? Users are unable to access the ThryvPay platform at this time. Users will get an error screen when attempting to access the ThryvPay platform. Business Center users who utilize ThryvPay as their payment processor may experience issues with processing customer payments at this time.
Include Geographic Scope: All ThryvPay users
Current Workaround: No available workaround at this time. If one becomes available this section will be updated.
We are working diligently to resolve this issue; we will provide ongoing status updates.
Next Update Scheduled For: 4:30pm CT
Posted Mar 11, 2026 - 15:27 CDT
This incident affected: Payments (ThryvPay, ThryvPay Mobile App) and Business Center (Sales).